Back to overview
Downtime
Dream Machine Login is Down
May 19 at 01:30pm UTC
Affected services
Dream Machine
Resolved
May 19 at 03:15pm UTC
Fix was deployed. Login is back.
Affected services
Dream Machine
Created
May 19 at 01:30pm UTC
The team is currently working on a fix
Affected services
Dream Machine