Back to overview
Degraded
Luma Agents experiencing issues
Apr 28, 2026 at 2:10pm UTC
Affected services
Luma Agents
Resolved
Apr 28, 2026 at 2:40pm UTC
service is now back to normal
Affected services
Created
Apr 28, 2026 at 2:10pm UTC
unable to load boards
Affected services